cPanel解决无法安装php5.2.7

  • A+
所属分类:PHP

做国外生意的朋友换购一台服务器,需要重新安装cPanel,花了几十美元买来的cPanel不支持5.2.17,最低版本支持到5.3.27,最高5.5,这让人非常恼火,上官网找解决方法,如下为安装php5.2.17的方法。

1. 准备cpanel专供php

# cd /var/cpanel/easy/apache/custom_opt_mods
# wget http://www.bhlaab.com/795/twiki/pub/EasyApache/EasyApacheCustomModules/custom_opt_mod-PHP5217.tar.gz
# tar -xzvf custom_opt_mod-PHP5217.tar.gz

2. 通过easyApache重装

搜索easyApache,然后一步步看图。

easyApache

cPanel安装php5.2.17

cPanel安装php5.2.17

cPanel安装php5.2.17

cPanel安装php5.2.17

 

然后和往常一样一步步往下走即可完成。

3.?php扩展配置

因为这不是cPanel原生的安装,所以没有php的扩展选项,它会根据php压缩包内的默认配置参数安装。如果你需要支持额外选项,例如gd和ftp,如下操作:

 

一行一个,它会解析成--with-gd --enable-ftp,然后整合到configure后面。

备注:安装模块的方法我没有实际测试,因为默认安装以及满足了朋友的要求,cPanel安装速度很慢,所以我不在测试了。

微信公众号
扫一扫关注运维生存时间公众号,获取最新技术文章~

发表评论


目前评论:5   其中:访客  3   博主  0   引用   2

    • ★Extreme★ 1

      不知道管理员为何要用PHP 5.2呢?我的WordPress也用PHP 5.5了,时时彩计划软件公式:不过我用的某个程序不支持5.5,所以另一个网站用着PHP 5.4。

        • 博主 9

          @★Extreme★ 某些外贸站点老旧,只能支持php 5.2

            • ★Extreme★ 1

              @博主 我的客户也遇到过某些程序用Zend Optimizer加密,无法用PHP 5.3以及以上版本的Zend Guard Loader的问题,后来全部升级5.3以上了,那个客户也只好走人了 ” /> 。

        • 来自外部的引用: 2

          • 冯先招斗
          • 程甲圻比